Statuspage posting to Microsoft Teams

Incident Report for University of Idaho

Resolved

This incident has been resolved by migrating to the new Workflows / Power Automate webhook supported by Atlassian and Microsoft.
Posted Jul 22, 2026 - 15:12 PDT

Investigating

We are currently investigating an issue with Statuspage not posting to Microsoft Teams.
Posted Jul 22, 2026 - 15:06 PDT
This incident affected: Cloud Services (Microsoft 365).