Canvas - Degraded Performance

Incident Report for University of Idaho

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 15:07 PDT

Update

Canvas users should be able to resume normal activity. The vendor has implemented a fix and is continuing to monitor.
Posted Aug 31, 2026 - 14:01 PDT

Monitoring

Canvas users are reporting degraded performance or are unable to access the application. We are actively monitoring the situation and awaiting communication from the vendor regarding the expected restoration timeline. We will provide further updates as information becomes available.

More information is available on the vendor's status page: https://status.instructure.com/
Posted Aug 31, 2026 - 11:23 PDT
This incident affected: Academic and Student Services (Canvas).