Accounts and Billing Outage

Incident Report for University of Idaho

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 08:20 PDT

Monitoring

Vendor maintenance is affecting the Accounts and Billing page in MyUI. We are monitoring for a resolution.
Posted Jul 15, 2026 - 15:02 PDT

Identified

We've contacted the vendor and it appears that this issue is related to maintenance work being performed today.
Posted Jul 15, 2026 - 14:48 PDT

Investigating

Some users are reporting that they are unable to access the Accounts and Billing page from MyUI. We are currently investigating the issue.
Posted Jul 15, 2026 - 14:19 PDT
This incident affected: Websites and Web Applications (MyUI).