MyUI Unresponsive

Incident Report for University of Idaho

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 16:21 PDT

Monitoring

A service outage with a cloud provider was resolved, and we are monitoring the results.
Posted Aug 18, 2025 - 13:14 PDT

Investigating

MyUI is currently experiencing intermittent and very slow response times. We are investigating the cause.
Posted Aug 18, 2025 - 08:44 PDT
This incident affected: Websites and Web Applications (MyUI).