Student Self-Service: Advisors Unable to Remove Holds

Incident Report for University of Idaho

Resolved

This incident has been resolved.
Posted May 05, 2025 - 17:01 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 05, 2025 - 16:39 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 05, 2025 - 16:30 PDT

Investigating

We are currently investigating an issue where Advisors are not able to remove holds in Student Self-Service.
Posted May 05, 2025 - 15:36 PDT
This incident affected: Academic and Student Services (Student Self-Service).