MyUI and other University of Idaho services intermittently unresponsive

Incident Report for University of Idaho

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 07:35 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 07:33 PDT

Identified

We are aware of intermittent issues accessing MyUI and other University Services. This is part of larger AWS service outage. We are monitoring the situation and working with Vendors and will provide updates as they are available.
Posted Oct 20, 2025 - 12:46 PDT
This incident affects: Websites and Web Applications (MyUI).