Softdocs - West US Region - Intermittent Connectivity Issues

Incident Report for University of Idaho

Resolved

Softdocs has reported that the issue affecting their services has been resolved.
Posted Jul 23, 2026 - 13:37 PDT

Monitoring

Softdocs has reported intermittent connectivity issues affecting systems in Azure's West US region. Softdocs is used for E-Forms and Workflows at U of I and is also known as Etrieve Content and Etrieve Central. At this time we are not aware of any U of I users being affected by this issue. We will continue monitoring the situation and communicate updates as they become available.

Users can check the Softdocs status page for further information here: https://uptime.com/statuspage/softdocsstatus
Posted Jul 23, 2026 - 09:05 PDT
This incident affected: Employee and Administration (Softdocs).