MyUI Card Outage

Incident Report for University of Idaho

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 15:13 PST

Monitoring

Functionality of MyUI cards has been restored. Continuing to monitor to ensure the downstream vendor's fix remains stable.
Posted Jan 20, 2026 - 08:51 PST

Investigating

We are currently investigating this issue.
Posted Jan 20, 2026 - 08:44 PST
This incident affected: Websites and Web Applications (MyUI).