www.uidaho.edu in a degraded state.
Incident Report for University of Idaho
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 11:32 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2024 - 10:25 PDT
Investigating
We are currently investigating an issue with www.uidaho.edu where some pages are failing to load.
Posted Apr 09, 2024 - 08:21 PDT
This incident affected: Websites and Web Applications (uidaho.edu).