Microsoft Outlook Consumer (OLC) email being blocked

Incident Report for University of Idaho

Resolved

Microsoft delisted a Proofpoint IP address at 11:24 AM. Monitoring shows no rejected messages in the past hour and the incident is marked as resolved.
Posted Jul 07, 2026 - 13:13 PDT

Identified

Email messages sent to Microsoft Outlook Consumer (OLC) domains, such as hotmail.com, live.com, etc, are being rejected. Support tickets have been opened with Microsoft and Proofpoint to address the issue.
Posted Jul 06, 2026 - 14:00 PDT
This incident affected: Cloud Services (Microsoft 365).