Network Outage - Degraded VPN Service

Incident Report for University of Idaho

Resolved

This issue was resolved with a network routing change made at 6:30pm on January 12th.
Posted Jan 14, 2026 - 15:32 PST

Identified

The U of I VPN is currently in a degraded state, especially regarding upload speeds while connected. More details can be found here: https://uidaho-private.statuspage.io/incidents/npw454j6n4kx
Posted Dec 18, 2025 - 13:30 PST
This incident affected: Network (VPN).