MyUI Cards Outage

Incident Report for University of Idaho

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 09:01 PST

Monitoring

Our vendor has applied a fix to this issue and is currently monitoring the results. We will continue to monitor and provide updates as necessary.
Posted Dec 12, 2025 - 08:12 PST

Identified

Our downstream vendor has identified an issue and are currently working to resolve the issue. We will continue to monitor and provide updates as necessary.
Posted Dec 11, 2025 - 16:21 PST

Investigating

We are currently investigating an issue preventing some MyUI Cards from being visible.
Posted Dec 11, 2025 - 08:33 PST
This incident affected: Websites and Web Applications (MyUI).